Jump to content

Photo
- - - - -

Class 'Core_Api_Core' not found in ...


  • Please log in to reply
1 reply to this topic

#1 mhbrownie

mhbrownie

    Level 1

  • Members
  • Level
  • 0 points
  • 2 posts

Posted 31 July 2018 - 04:29 PM

Hello, I am working on a customer's site who has an old version of Social Engine (circa 2012, 2013).

 

I was attempting to update the core.php file located under /<site>/application/modules/Group/Api. After making a set of updates I started to get a 500 error on the site and found this in the error log:

 

PHP Fatal error:  Class 'Core_Api_Core' not found in /var/www/vhosts/<site>/application/libraries/Engine/Loader.php on line 163

 

I reverted back to the original core.php and still see the same error. The changes to the Core.php were the only changes I had made.

 

Given the file is there (and it appears the permissions are correct). Any ideas? The apache instance has been reset. I know there is some zend based caching but I wouldn't think it would survive a reset?

 



#2 jedacandy

jedacandy

    Level 1

  • Members
  • Level
  • 0 points
  • 3 posts

Posted 28 September 2021 - 10:12 AM

I have seen it for days, agree with the information you shared, it helps me a lot scribble io






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


All the resources listed here are just for testing purpose and they shouldn't be used at any commercial environment without a valid license.
Those are for users who wants to try them before buy. Help the developer to build it better by purchasing them from original authors.