Jump to content

sunyan

Member Since 26 Jul 2011
Offline  Last Active Oct 26 2012 06:05 AM
-----

Posts I've Made

In Topic: Nginx + php-fpm need nginx rewrites

06 May 2012 - 12:31 PM

:evilgrin: I using nginx now. this is my config-files :
nginx.conf
user  www-data;
worker_processes  2;
error_log  /var/log/nginx/error.log;
worker_rlimit_nofile 65535;
pid        /var/run/nginx.pid;
events {
    worker_connections  65535;
}
http {
               include       mime.types;
       default_type  application/octet-stream;
	   add_header X-UA-Compatible 'IE=EmulateIE7';
       server_names_hash_bucket_size 128;
       large_client_header_buffers 4 4k;
       client_max_body_size 8m;
       client_header_buffer_size 4k;
       sendfile        on;
       tcp_nopush      on;
       open_file_cache max=65535 inactive=60s;
       open_file_cache_valid 60s;
	   server_tokens off;
       open_file_cache_min_uses 1;
       send_timeout        10;
  ####fastcgi module#######
       fastcgi_connect_timeout 300;
       fastcgi_send_timeout 300;
       fastcgi_read_timeout 300;
       fastcgi_buffer_size 4k;
       fastcgi_buffers 128 4k;
       fastcgi_busy_buffers_size 128k;
       fastcgi_temp_file_write_size 128k;
       keepalive_timeout  180;
###########about gzip module #####
       gzip  on;
       gzip_min_length  1024;
       gzip_comp_level   9;
       gzip_http_version 1.1 ;
       gzip_buffers     4 16k;
       gzip_types  text/plain text/css application/x-javascript text/xml application/xml application/xml+rss text/javascript application/atom+xml;
       gzip_vary on;
       gzip_disable “MSIE [1-6]\.(?!.*SV1)”;
       charset utf8;
       log_format  main  '$remote_addr - $remote_user [$time_local] '
                     '"$request" $status $body_bytes_sent '
                     '"$http_referer" "$http_user_agent"';
                     include           vhosts/*.conf;
        }
vhost.conf
server {
    listen       80;
    server_name  www.babystar100.com;

    #charset koi8-r;
    #access_log  /var/log/nginx/log/host.access.log  main;

    root   /data/www/html;
    index   index.php index.html;


    location ~* ^.+.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt|htm)$ {
    access_log off;
    expires 30d;
    }
    # Add expires header for static content
    location ~* \.(js|css|jpg|jpeg|gif|png|swf)$ {
    if (-f $request_filename) {
       root /data/www/html;
       expires      1d;
       break;
    }
    }
    
    # Get rid of index.php
     location /index.php {
     rewrite ^/(.*)$ /index.php?rewrite=2 last;
    }

    # Rewrite all directory-looking urls
    location ~ /$ {
     rewrite ^/(.*)$ /index.php?rewrite=1 last;
    }

    # Try to route missing files
    # If the file doesn't exist, rewrite to index
    try_files $uri $uri/ @exist;
    location @exist {
    rewrite ^(.*)$ /index.php?rewrite=1 last;
    }

    #location / {
    #    root   /data/www/html;
    #    index  index.php index.html index.htm;
    #}

    #error_page  404              /404.html;

    # redirect server error pages to the static page /50x.html
    #
    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
        root   /data/www/html;
    }

    # proxy the PHP scripts to Apache listening on 127.0.0.1:80
    #
    #location ~ \.php$ {
    #    proxy_pass   http://127.0.0.1;
    #}

    # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
    #
    location ~ \.php$ {
        fastcgi_pass   127.0.0.1:9000;
        fastcgi_index  index.php;
        fastcgi_param  SCRIPT_FILENAME  /data/www/html$fastcgi_script_name;
        include        fastcgi_params;
    }

    # deny access to .htaccess files, if Apache's document root
    # concurs with nginx's one
    #
    #location ~ /\.ht {
    #    deny  all;
    #}

    location /install/ {
    root /data/www/html/install;
    index index.php;
    if (!-e $request_filename) { rewrite ^(.*)$ /install/index.php?rewrite=1; }
    }

}

I hope this can help anyone .

In Topic: Fixing the points/spend link error in Rewards Shop Help Page

25 February 2012 - 06:31 AM

No thanks. I hope this can help anyone . :evilgrin:

Thank You SOOO much!


In Topic: Fixing the points/spend link error in Rewards Shop Help Page

12 February 2012 - 09:35 AM

I solved this bug . my site is work fine now . at here ill tell anyone.
1st. download this file : This file ,use it replace "application/modules/Activitypoints/Form/Admin/settings.php" .
2nd. go to admin>plugins>activity points >Global Settings>disable every items .
3rd, Flush your cache .
4th,go to admin>plugins>activity points >Global Settings>enable every items and save change.

now go to your site font , click topuser link . you can see all your want .

dont forget +REp <_<


Hello, someone tell me to reshare this file. I share it here again . you can clickthis linkto download.

In Topic: Illuminent Blue

14 December 2011 - 03:03 PM

Its great! thanks very ....much !!

In Topic: auto grow wall feed

12 November 2011 - 10:46 AM

can't work in 4.1.8. cant find "var endOfFeed = <?php echo ( $this->endOfFeed ? 'true' : 'false' ) ?>;" in application/modules/Activity/widgets/feed/index.tpl .



All the resources listed here are just for testing purpose and they shouldn't be used at any commercial environment without a valid license.
Those are for users who wants to try them before buy. Help the developer to build it better by purchasing them from original authors.